Text Editing tutorial: Part 3

This tutorial develops the simple wxWidgets text-editing program, and here we add a Help Menu

Adding a Help menu 
  1. An About box: In the Menuzone, click Add menu | New menu and type Help use Add | menu and then New Item and type About
  2. Double click the About replica, and use Insert Dialog | About with Picture.  Edit the text and create a file called about.png in the same directory as the  project code files to act as a pretty logo
  3. Compile and run the project.
  4. A Help Contents page : use Add | menu and then New Item and type Contents
    Double click the Contentsreplica, and use Insert Dialog | HTML page viewer. By default, this shows index.html from the project directory, so use Mozilla's composer, or other HTML editor to create a nice index.html page (it can include graphics)
  5. I prefer the Contents to be above About, so go to the menuzone, hold the mouse down on the Contents replica and drag it up, letting it go on the Help replica.
  6. Compile and run the project.
Suggestions for further work
  1. You could use the method used to implement Find to implement an Uppercase and Lowercase menu items
  2. You can add Recent files to the File menu (use Insert Code | Recent files)
  3. You can use Insert Code | CommandLine parser to make your editor open files passed on the command line
  4. You can  Insert Code | Splashscreen , and right click on splash.png, This will offer a direct Edit  Image  menu item
  5. Try the Dialog Tutorial, which will allow you to add better Search/Replace and Help viewers
Back
Dialog Tutorial

wxHatch Home link to wxhatch help index